Ofimega — Centre de formacié — Introduccion a la programacion — Ejercicios del alumno en el centro

Introduccion a Rad Studio XE Delphi - C++ builder - Firemonkey

Embarcadero Rad Studio es un IDE Interface de Desarrollo del tipo RAD (Disefio rapido de
aplicaciones) que permite utilizar la programacién orientada a objetos utilizando como base
dos lenguajes:
» El lenguaje C++ en modo visual denominado C++ Builder. Aunque también permite hacer
aplicaciones C++ de consola.
» El lenguaje Pascal orientado a objetos denominado aqui Delphi.
Librerias y entorno:
» Este IDE comparte las mismas funciones y librerias bdsicas creadas exlusivamente para el
sistema operativo Windows (32 y 64), llamadas VCL tanto para Delphi como para C Builder.
» Las versiones XE incorporan la variante Firemonkey o entorno multi-device que permiten
compilar en multiplataforma OS — Android e incluso dispositivos méviles.
Par mas informacidn véase la pagina: http://docs.embarcadero.com/products/rad studio/

Conceptos basicos de programacidn.

=  Proyecto. Un proyecto es un conjunto de médulos de formulario, de cédigos y de archivos
gue componen una aplicacion. La ventana View » Project Manager muestra todos los
archivos que componen una aplicacion.

=  Formulario. Ventana con el disefio y el cédigo asociado a dicho formulario.

= Componentes. Los componentes son objetos como cuadros, botones, etiquetas... que se
disponen en un formulario o ventana para manipular o mostrar datos. Para poner los
componentes en un formulario usar la Tool Palette.

= Propiedades. Usando la ventana de Object inspector (F11) se definen las propiedades de
formularios y controles. Las propiedades especifican los valores iniciales de las
caracteristicas, tales como tamafio, nombre y posicion.

= Eventos: Es la respuesta a las acciones del usuario que desencadena una accién en el
programa.

Concepto de cédigo:

Es el texto escrito en un programa. El programa se divide en distintos apartados o subrutinas

generalmente como respuesta a un evento y se divide en procedimientos (subrutinas) o

funciones.

= Acciones o subrutinas: Trozos de codigo como respuesta a un evento o accion. No recoge
ni devuelve ningun dato.

Tool Palette p

+ Standard

+ Additional

+ 'Win32

+ System

+'Win 3.1

+ Dialogs

+ Data Access

+ Data Controls

+ dbExpress

+ Datasnap Server
+ FireDAC

+ LiveBindings

# LiveBindings Misc
+ FireDAC Devs

+ Vista Dialogs

+ Sensors

+ Samples

+ Touch

+ Gestures

+ dbGo

+ InterBase Admin
# Internet

+ WebServices

+ DataSnap Client
+ Xml

+ Net

+ BAAS Client

Rl PO ] |-

= Procedimientos: Trozos de cddigo como respuesta a un evento o accion. No devuelven ningun valor pero si

puede recoger uno o varios parametros (especificados entre paréntesis).

= Funciones: Son procedimientos que ademds devuelven un valor al procedimiento desde donde se le llamé.
= Diagrama de Flujo: Representa la esquematizacién grafica de un algoritmo, el cual muestra graficamente los

pasos 0 procesos a seguir para estructurar bien un programa.

Eventos y acciones (sobre un componente):

Propiedades basicas de los objetos:

Lista de eventos (Desencadena la accion de un objeto) Alignment - Alineacion

Bevellnner - borde interior

Evento Accién BorderStyle - estilo del borde

Click Al hacer clic con el mouse (o el teclado) Caption - rétulo

DragDrop Al soltar un control arrastrado con el mouse TabStop - Salto tabulacién

DragOver Al Arrastrar un control con el mouse. Color, Cursor - Color, puntero

KeyDown Presionar una tecla mientras el objeto tiene el foco. Enabled - Activo

KeyPress Presionar una tecla y devolver su valor ASCII. Font - Tipo letra

KeyUp Liberar una tecla mientras el objeto tiene el foco. Height - Altura del objeto

MouseDown Presionar el botdn del mouse sobre el objeto. Hint - Etiqueta ayuda

MouseMove Mover el puntero del mouse por encima del objeto Left - Posicion izquierda

MouseUp Liberar el botdn del mouse en el objeto. Name - Nombre del objeto
PopupMenu - Menu contextual
ShowHint - Mostrar etiquetas
Top - Posicidn vertical
Visible - Visible
Width - Ancho del objeto




Acceso al programa RAD Studio

En el menu de Inicio de Windows - Todas las Aplicaciones — Embarcadero. Dispones de un acceso directo para crear
solo proyectos en Delphi o sélo C++ Builder o el acceso a RAD Studio para crear un proyecto en cualquiera de los
dos lenguajes.

Crear y guardar un proyecto:

Prepara la carpeta de trabajo: En primer lugar, antes de trabajar con un proyecto, ya sea Delphi o C++, es
aconsejable que crees una carpeta (subdirectorio) con el nombre del proyecto para separar el conjunto de archivos
que contendra cada uno de ellos. RadStudio XE? genera en la carpeta de documentos personales, una carpeta
Projects para guardar los proyectos:
Ruta de muestra: C:\Users\Ofimega\Documents\Embarcadero\Studio\Projects
y en los documentos publicos pone las carpetas compartidas como los ejemplos:
Ruta de muestra: C:\Users\Public\Documents\Embarcadero\Studio\17.0\Samples
Crear un Proyecto en Delphi:
» Para hacer aplicaciones de escritorio Windows:
Escoge del menu de Rad Studio la opcion: File » New — VCL Forms Application Delphi
(6 File » New — Application Delphi, segun las versiones)
» Para hacer aplicaciones multidispositivo Firemonkey:
Escoge del menu de Rad Studio la opcidén: File » New — Multi-device Application - Delphi
(6 File » New — Firemonkey desktop application Delphi, segun las versiones)
Crear Proyecto en C++ Builder:
» Para hacer aplicaciones de escritorio Windows:
Segun las versiones, escoge del menu de Rad Studio la opcién: File » New — Application C++ Builder
6 File » New — VCL Forms Application C++Builder
» Para hacer aplicaciones multidispositivo Firemonkey:
Segun las versiones, escoge del menu de Rad Studio la opcion: File » New — Multi-device Application - C++
Builder ¢ File » New — Firemonkey desktop application C++ Builder
Guardar un proyecto en Delphi
» Primero hay que guardar la unidad principal de la aplicacion, ej: Holal.pas donde se encuentra el cddigo fuente
en Pascal. Se genera por defecto el archivo del formulario asociado: Holal.dfm que contiene el disefio de la
ventana.
» Finalmente guardamos el archivo del proyecto conjunto Hola.dproj que también genera Hola.dpr para versiones
anteriores de Delphi.
Guardar un proyecto en C++Builder
Primero guardamos el archivo fuente Holal.cpp que genera por defecto el archivo del formulario Holal.dfmy
el archivo cabecera de unidades internas: Holal.h. En segundo lugar, guardamos el archivo cabecera: Hola.h
que incluye las unidades externas y finalmente guardamos el archivo del proyecto conjunto Hola.cbproj.

Reglas de nomenclatura al declarar procedimientos o variables:
» Deben comenzar por una letra » No pueden contener puntos
» No puedes superar los 255 caracteres » Nombres de formularios no sobrepasar 40 caracteres
» No pueden tener el mismo nombre que una palabra clave

Comentarios en el cédigo
» En una linea: Se inician con: // tanto para Delphi como para C++
» Envarias lineas: Delphivanentre{ ... } C++van entre los signos /* ... */

Normas para escribir el cédigo:

Para referirmos o cambiar una propiedad de un objeto en tiempo de ejecucidn:

En Delphi: Escribiremos el nombre del objeto, un punto y su propiedad:
Ejemplo: Buttonl.Caption="Vale’; siasignamos una cadena de texto ira entre apdstrofes

En C++: Escribiremos el nombre del objeto, una flecha formada por los caracteres -> y su propiedad:
Ejemplo: Buttonl->Caption="Vale"; siasignamos una cadena de texto ira entre dobles comillas

Atencidn a las mayusculas en C++: Importante escribir “Button” con la 12 letra en mayusculas, ya que C++ distingue

mayusculas de minusculas.

Para asignar un valor a un objeto o variable

En Delphi:  Se indica con H Ejemplo: ProgressBarl.position :=100;

En C++: Se indica con = Ejemplo: ProgressBarl->Position = 100;

Para comparar el valor de un objeto o variable

En Delphi:  Se indica con el signo igual E| Ejemplo: if ProgressBarl.position=100 then ...

En C++: Se indica con el doble signo igual E| Ejemplo: if (ProgressBarl.Position == 100)

v

v

v
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Introduccion a Rad Studio: Delphiy C++

Lenguaje base

Estructuras de control

if (comparador si-entonces)

if...else (comparador si...sino)

for (bucle con contador)

switch / case (comparador multiple)

while (bucle por comparacion booleana)
break (salida de bloque de cddigo)

continue (continuacion en bloque de codigo)
return (devuelve valor a programa

Tipos

boolean (booleano)

char (caracter)

byte (entero hasta 226)

int (entero)

unsigned int (entero sin signo)

long (entero 32b)

unsigned long (entero 32b sin signo)
float (decimal de coma flotante de 16b)
double (decimal coma flotante de 32b)
string (cadena de caracteres)

Operadores

asignacion C = Delphi :=
iguala C == Delphi=
suma+ resta -
multiplicacién *

division /

resto %

distinto de C I= Delphi <>
menor que <

mayor que >

menor o igual que <=

mayor o igual que >=

y && o || DelphiAnd-Or
negaciéon ! Not

incremento / decremento ++ --

Funciones matematicas

min () (minimo)

max () (maximo)

abs () (valor absoluto)
sq () (eleva al cuadrado)

= array (cadena matriz) sqrt () (raiz cuadrada)
= void (vacio) sin () (seno) cos () (coseno) tan () (tangente)
» Comparadores:

Comparador Delphi C++ ejemplo
Igual = == if ProgressBarl.position=100 then showmessage (‘Has llegado a 100’);
Mayor > > if ProgressBarl.position>100 then showmessage (‘Te has pasado de 100’);
Menor < < if ProgressBarl.position>100 then showmessage (‘Alun no has llegado a 100);
Mayor o igual >= >= if edad>=100 then showmessage (‘Has llegado o te has pasado de 100’);
Menor o igual <= <= if edad<=100 then showmessage (‘Aln no has llegado a 100);
Distinto <> = if edad < > 100 then showmessage (‘No es 100’);

Conversion de tipos:

IntToStr (Integer to String) » Cambia del tipo de nimero entero a cadena de texto
StrTolnt (String to Integer) » Cambia del tipo cadena de texto a nimero entero
Otros:
StrToFloat (texto a decimal flotante)
FloatToStr (Decimal flotante a texto))
FloatToDecimal (Decimal flotante a decimal
Formatfloat (Decimal flotante a texto con formato)

DateTimeToStr (Fecha/hora a texto)
DateToStr (Fecha a Texto)
StrToTime (Texto a hora)
StrToDate (Texto a fecha)

Ventanas de mensaje. (3 métodos para mostrar o pedir mensajes al usuario):

1. Usando las funciones VCL internas que incorpora C++Builder:
» ShowMessage(): Muestra un mensaje de texto en una ventana
MessageDlIg(): Muestra una ventana con mensaje y botones de respuesta
Los botones de accion pueden ser: mbOK — mbCancel — mbYes — mbNo — mbAbort — mbRetry — mbClose
Y sus repuestas son: mrOk - mrCancel — mrYes — mrNo — mrAbort — mrRetry - mrClose
MessageDIgPos() idem pero con posibilidades extras
2. Usando las funciones de la APl de Windows

-

v

v

respuesta que pueden ser: MB_OK - MB_OKCANCEL- MB_ABORTRETRYIGNORE - MB_YESNOCANCEL - MB_YESNO -
MB_RETRYCANCEL - MB_HELP
3. Creando nuestros propios formularios/ventanas:
- Primero: crear un nuevo formulario secundario: Flie — New — Form donde se pondra el mensaje y los botones
- Segundo: incluir la unidad del formulario en la principal: #include "secundario.h" o USES
- Tercero: Mostrar la ventana utilizando las funciones show() o showmodal();
Pedir datos al usuario en ventanas:
1. Utilizando ventanas con entradas de texto:
» InputBox('Nombre_ventana', 'Texto_Dato', 'Respuesta_predeterminada'); = Devuelve Var String
» InputQuery('ldentificate!', 'Pon tu nombre, por favor...", Nombre); = Devuelve Var Bolean
2. Aifadiendo componentes de didlogo estandar al formulario desde la paleta Dialogs:
- Opendialog — Savedialog: Componentes para abrir y guardar archivos
- PrintDialog — PrinterSetupDialog - PageSetupDialog: Componentes para imprimir y configurar impresién
- FontDialog — ColorDialog - FindDialog: Cambiar la fuente, el color o buscar texto.

Application->MessageBox(): Muestra un mensaje de texto en una ventana de Windows estandar con o sin botones de



Ejercicios basicos. Crear una ventana “hola mundo”.

Ejercicio 1: H Tool Palette  Paleta de

Crear la aplicacién en Delphi: % ~| [y | Q se herramientas

= Escoge del menu: File » New » VCL Form Applicaton - Delphi para (- Standard

crear un nuevo proyecto en Delphi. T Marcos
Te aparecerd una ventana o formulario vacio (Form). & TMainMenu  Men principal
En el panel Inspector de objetos (Object Inspector), veras las I, TPopupMenu  Mend secundario
propiedades de la ventana o de los objetos que en ella pongas. “= TlLabel Etiqueta

= Desde la barra de herramientas Tool palette, En la seccién estandar TEdit Cuadro de Edicion

busca el componente TButton y arrastralo sobre el formulario (se
mostrara el botén Button1).
= Desde el panel de Properties, cambia su propiedad Caption por:
Aceptar
= Pulsa doble clic sobre el botdn e introduce el cédigo (en el evento
OnClic del botén Button1): B TustBox Cuadro de lista
B TComboBox Cuadro combinado

TMemo Texto MEMOria
Botdn

[% TCheckBox Casilla de verificacidn
@ TRadicButton Botdn de radio

procedure TForml.ButtonlClick(Sender: TObject); EE TScrollBar Barra de desplazamiento
begin i
Buttonl.Caption:='vale'; (1] Form1 o || B[ E
ShowMessage ('Hola mundo'); LN
end; LN
. , e N S R S
= Compilar vy probar el programa: Pulsa el botén Run [> o CTIiTiUNG Aceptar @Dl
elige del mend: Run - run. ::::::::::::::*.’....‘?...;?\\:::::::::::::
Comprueba su funcionamiento correcto cerrando la Cooooiioiocoiorioooos Name: Buttond

ventana. Sooooooioriooiooiooioo Caption: Aceptar

= Guardar el proyecto y los archivos fuentes en Delphi

19. Abre la carpeta de tus projectos y crea la subcarpeta: Holamundo
22, Para guardar la ventana del formulario y su cddigo asociado elige del menu: File » Save all
» El archivo que contiene el cédigo en pascal se llamard Holal.pas
» El archivo que contiene el proyecto se llamara Hola (*.dpr o *.pdroj)
= Cerratodo el proyecto: Elige del menu: File » Close all...

Crear la aplicacion en C++ Builder:

= Escoge del menu: File » New » VCL Form Applicaton — C++ Builder para crear un nuevo proyecto en C++ Visual.
= Repite los mismos pasos para afiadir desde la Tool palette un boton TButton sobre el formulario (Button1).

= Desde el panel de Properties, cambia su propiedad Caption por: Aceptar

= Pulsa doble clic sobre el botdn e introduce el cddigo (en el evento OnClic del botén Buttonl):

void _ fastcall TForml::ButtonlClick(TObject *Sender)

{ //Cuidaddo: C++ distingue mayusculas
Buttonl->Caption="Vale"; //cambia el texto del botodn
ShowMessage ("Hola mundo"); //muestra un mensaje

}

* Prueba la aplicacion pulsando en el botédn Run > o la tecla: F9
= Si funciona correctamente, guarda la aplicacion: File » Save all
» El archivo que contiene el cddigo se llamara Holal.cpp
» El archivo cabecera: HolalH.h
» El archivo del proyecto: Hola.cbproj
Comparartiva con Microsoft Visual Estudio

Mismo ejercicio en Microsoft C#: private void buttonl_Click(object sender, EventArgs e)
{ buttonl.Text = "Vale";

Mismo ejercicio en Microsoft Visual C++ : )
private void buttonl_Click(object sender, EventArgs e)
¢ buttonl->Text = "Vale";
}

Mismo ejercicio en Microsoft Visual Basic:

Private Sub Buttonl_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
Buttonl.Text = "Vale"
End Sub
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Ejercicio 2:

= Abre el proyecto anterior. En Delphi o C++ usando laopcién 5= .. ... . . .. . 00

del mendu: File - Open Project... i

= Desde la Tool palette, aifiade al ejercicio anterior un

componente TEdit y un componente TlLabel con las - - - - - .~ -

propiedades de la imagen:

Aceptar | ... ... L.
. oosas oo Name: Button1 -
Caption: Mombre: 0000 .
Pt coioooo Caption: Aceptar
En Delphi | En C++
Afadir al OnClick del botén Button1: Afadir al OnClick del botén Button1:
procedure TForml.ButtonlClick(Sender: TObject); void _ fastcall TForml::ButtonlClick(TObject *Sender)
begin ShowM "Hol " Editl->Text "
owMessage("Hola + Edit1->Text + ".");
ShowMessage('Hola, ' + Editl.Text + '.'); } ge( ’ )
end;

Guardar los proyectos:

Al guardar el proyecto, se deben guardar antes varios archivos que contengan el cédigo y el disefio. Por eso es

importante guardarlo todo en una carpeta.
» Enlared: Escojey abre tu carpeta de alumno de la red
» En el equipo: Abre la carpeta: Documentos\Embarcadero\Studio\Projects
crea dentro una subcarpeta con tu nombre
Crea la carpeta: SaludoNombre

En Delphi:
» Primero te pedird la unidad del tipo (*.pas): Pon el nombre: DSaludoNombre1.pas
» Luego te pedira el nombre del proyecto (*.dproj): Pon el nombre: SaludoNombre

Se generaran otros archivos como SaludoNombrel.obj que es el archivo objeto con el cédigo maquinay

SaludoNombrel.dfm que es el archivo de disefio del formulario.

En C++ Builder:
» Primero te pedird la unidad del tipo (*.cpp): Pon el nombre: SaludoNombreC1.cpp
» Luego te pedira el nombre del archivo cabecera: Pon el nombre: SaludoNombreC.h
» Luego te pedira el nombre del proyecto (*.cbproj): Pon el nombre: SaludoNombreC

Se generaran otros archivos como SaludoNombreC1.h que es el archivo cabecera de la unidad y

SaludoNombreC1.dfm que es el archivo de disefio del formulario.

Esta técnica te servird para guardar los siguientes proyectos y ejercicios.



Ejercicio 3. Contador:  Objetivo: practicar con la conversién de datos y las propiedades

Recuerda la conversién de tipos de datos:
IntToStr (Integer to String) » Funcién que cambia un valor del tipo numérico entero a cadena de texto
StrTolnt (String to Integer) » Funcién que cambia un valor del tipo cadena de texto a nUmero entero

= Recupera el ejercicio anterior.

= Cambia el texto (propiedad caption) del botén por: 0

= Aflade un segundo botén a la ventana formulario desde la
paleta Tool palette — seccidn Standard: Tbutton
Al botdn 2 cambia el texto (propiedad caption) por Contar
Pulsa doble clic encima de él, para abrir la ventana de cédigo.

En Delphi En C++ |
Anadir al OnClick del botén Button2: Anadir al OnClick del botdn Button2:
procedure TForml.Button2Click(Sender: TObject); void _ fastcall TForml::Button2Click(TObject *Sender)
begin { . .
Buttonl.Caption:=InttoStr(StrToInt(Buttonl.Capt Buttonl->Caption = StrToInt(Buttonl->Caption) +1;
ion) +1);
end;
Guarda el proyecto con el nombre: ContadorDelphi Guarda el proyecto con el nombre: ContadorC

Variables y constantes:

e Una variable es un registro o porcién de memoria que contendra un dato o valor y al que le asignaremos un nombre
cualquiera. Al crear esta variable le tendremos que especificar qué tipo de dato o valor va a guardar. Este valor
puede cambiar a nuestro antojo, en cualquier momento del programa (durante su desarrollo o en ejecucion).

e Una constante se crea y declara como una variable, pero normalmente, el valor que le asignemos inicialmente no
cambiard durante toda la ejecucion del programa.

o Variables publicas y privadas. Si una variable o constante se crea o declara dentro de un procedimiento o funcidn
se considera privada de esa funcidn porque sélo servira o existird para esa funcién. Al salir de la misma ya no
permanecera en la memoria (liberamos memoria) y su nombre se podra emplear en otro lugar, pero no podra ser
utilizada en otro procedimiento o funcion.

Si por el contrario la variable o constante es declarada al inicio del programa, antes que los procedimientos o
funciones, se considera publica. Existira durante todo el programa y podra ser utilizada por todas las funciones del

programa.

Eiemplo en Delphi: Eiemplo en C++ Builder:
La variable hay que declararla o crearla antes de ser | Se indica el tipo de variable y luego su nombre. Se suele
utilizada con un nombre y su tipo de dato. aprovechar la declaracion para asignarle ya un valor.
var
NumPeque: byte; //entero hasta 256 byte numPeque=3; //declara y asigna num hasta 256
NumEnte: integer; //entero int numEnte = 500; // numero entero
NumDeci: single; //decimal simple float numero=3.5; // declara un numero decimal
NumDeci2: double; //decimal doble boolean correcto=true;
Correcto: boolean; //logico char letra = 'A'; // Declara y asigna el caracter A
Letra: char; //caracter
const const float PI = 3.1416; //constante tipo decimal

Pi = 3.1416; //supone que es float
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Ejercicio 4. Contador con limite Objetivo: practicar con el estado condicional if y variables

= Recupera el ejercicio anterior y cambia el cédigo anterior por:

En Delphi/Pascal | En C++
procedure TForml.Button2Click(Sender: TObject); void _ fastcall TForml::Button2Click(TObject *Sender)
var //seccién para variables {
i:integer; //declaro la variable entera i int i; //declaro la variable i para usar como contador
begin i=StrToInt(Buttonl->Caption); //coge el valor del botdnil
i:=strtoint(Buttonl.Caption); //pongo el valor if (i==6)
if i=6 then i:=1 else i:=i+1l; //si llega a 6.. {
Buttonl.Caption:=inttostr(i); //mostramos i i=1; //si ya vale 6 la ponemos a 1
end; }
else // y si no..
{
i++; // le incrementamos 1
}
Buttonl->Caption = StrToInt(i); //ponemos i en el botdnl
)i

Teoria: Diagrama de flujo o flujorama

Es la represenacion grafica o esquematica de la o
secuencia que realiza un algoritmo o subrutina Inicio
No depende del lenguaje de programacién. l
Ejemplo de diagrama de flujo del ejercicio anterior - R -
> 1=

Explicacion del algoritmo:
Creamos una variable llamada i que contendra un

valor numérico entero y que usaremos como i=boton
contador. Muestra boton

Al pulsar el botdn2, la variable i cogera el valor que
esta mostrando el botdn1 (que debe ser un nimero)

y este valor de i lo comaparemos con el 6 en la o
instruccion IF. Boton=i
Siiaun no hallegado a 6 le sumamos 1 (i=i+1) o le ?

incrementamos 1 (i++).
Siiya ha llegado a 6 le reasignamos el valor 1. i=i+1

Si No 1
Guarda los proyectos

Guarda el proyecto ContadorDelphiy el proyecto
ContadorC.

Ejercicio 5. Generar un humero aleatorio

= Recupera el ejercicio anterior.
= Afiade un tercer botdn a la ventana formulario desde la paleta Tool palette — seccidn Standard: Tbutton
= Al botdn 3 cambia el texto (propiedad caption) por Aleatorio y pulsa doble clic encima |, para poner el cédigo.

En Delphi: En C++ Builder:
procedure TForml.Button3Click(Sender: TObject); void _ fastcall TForml::Button3Click(TObject Sender)
begin {

randomize; // llamada a procedimiento randomize;
Buttonl.Caption:=inttostr(random(5)+1); Buttonl->Caption=IntToStr(random(5)+1); }
end;

Guarda los proyectos: Guarda el proyecto ContadorDelphiy el proyecto ContadorC.



Intrucciones condicionales
° If

La instruccion if puede usarse para ejecutar una instruccidn sélo si se cumple una cierta condicion (if-then ;
si...entonces), o para elegir entre dos alternativas (if-then-else; si...entonces..., y, si no, ...)

e (Case - Swith

Case permite evaluar distintas condiciones segiin un valor ordinal, en una lista de posibles valores.

Ejercicio condicionales

v

ingredientes:

= Un Label — con el caption: ¢Quién crees que ganara la liga?
= Dos casillas de seleccién: Con el caption: Barga y Real Madrid

= Cuatro botones en el formulario.

v

Nota:

En Delphi/Pascal:
procedure TForml.ButtonlClick(Sender: TObject);
begin // instrucciodn 1if
if CheckBox1l.Checked then
ShowMessage ('Has activado Barg¢a')
end;

procedure TForml.Button2Click(Sender: TObject);
begin // instruccion if-else

if CheckBox2.Checked then
ShowMessage (Has activado Real Madrid')
else
ShowMessage (“NO has activado Real Madrid);
end;

procedure TForml.Button3Click(Sender: TObject);
begin

// 1instruccion de doble condiciodn

if CheckBox1.Checked and CheckBox2.Checked
then

ShowMessage (Has activado los dos equipos')
end;

procedure TForml.Button4Click(Sender: TObject);
begin
// 1instruccion if compuesta
if CheckBox1l.Checked then
if CheckBox2.Checked then
ShowMessage( ‘Has activado los dos equipos')
else
ShowMessage( 'Sélo la casilla 1 estd
activada')
else
ShowMessage (
"La casilla 1 no estd activada. ¢A quién
Le importa La 2?'")
end;

Guarda los proyectos

Crea una aplicacion nueva (File » New » VCL Form Applicaton) y coloca los siguientes

Haz doble clic en cada botén para aiadir cédigo al evento OnClick:
La instruccion if-then-else, es una sola instruccidn, asi que no
puede colocar un punto y coma en medio de ella.

£QUién crees que ganard la liga? -

[ IBarca [ ]Real Madrid
Buttonl Button3
Button2 Button4

En C++ Builder:

void _ fastcall TForml::ButtonlClick(TObject *Sender)

if (CheckBox1->Checked) {
ShowMessage ("Has activado Barg¢a");

void _ fastcall TForml::Button2Click(TObject *Sender)

{
if (CheckBox2->Checked) {
ShowMessage ("Has activado Real Madrid");

}
else
{ShowMessage ("NO has activado Real Madrid");
}
}
F

{
if (CheckBox1->Checked && CheckBox2->Checked) {
ShowMessage ("Has activado los dos equipos");

void _ fastcall TForml::Button4Click(TObject *Sender)
{
if (CheckBox1->Checked) {
if (CheckBox2->Checked) {
ShowMessage("Has activado los dos equipos");
}
else
{ ShowMessage("Sé6lo la casilla 1 esta
activada");
}
}

else
{ ShowMessage("La casilla 1 no esta activada.
¢A quién le importa la 2?");

Guarda el proyecto CondicionalDelphiy el proyecto CondicionalC.
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Estructura condicional. Toma de decision
En Pascal:

if comparacién then accién_verdadera

else accion_falsa ; o sy Verdadero

En C++:

if (comparacién) { accién_verdadera; }
else { accion_falsa; }

Realizara una accion u otra segun si cumple una comparacion
Asignar o comparar un valor en Delphi/Pascal.

= Para asignar un valor a un objeto o variable se indica con E| Ejemplo: ProgressBari.position := 100;

» Para comparar el valor de un objeto o variable se indica con E| Ejemplo: if ProgressBarl.position =
100. .

Asignar o comparar un valor en C++.

= Para asignar un valor a un objeto o variable se indica con | 3
= Para comparar el valor de un objeto o variable se indica con |==]| Otros comparadores son:

Comparador simbolo ejemplo

Mayor > if ProgressBarl.position>100 then Showmessage (‘Te has pasado de 100’);
Menor < if ProgressBarl.position>100 then Showmessage (‘Aln no has llegado a 100);
Mayor o igual >= if edad>=100 then Showmessage (‘Has llegado o te has pasado de 100’);
Menor o igual <= if edad<=100 then Showmessage (‘Aun no has llegado a 100’);

Distinto <>¢ I= if edad <> 100 then Showmessage (‘No es 100’);

Ejercicio ventana con barra de progreso (hacer en modo Windows VCL y modo Multidevice FMX)

= Crea un nuevo proyecto para Windows: File » New » Windows VCL Application (Delpphi o C++ Builder).

Disefio: Timerl T ¥ H
- . . Properties | 11mer mer q
= Afiade al formulario un objeto - ';I . = L2 B L -l
na E ruE ...............................................
Darra e Proges et Interval 100 [ TR D gy
IProgressBar (delapaleta nane Tmerl | fmeri. . Tenendoarchivosamaentasl
win3 ),dosbotongs Tag 0 Coiliiiiiiiiiiiiiiiiiiiiiiiiiiiiiiio ProgressBarl:
(tButtons), una etiqueta tLabel Bl / JIRALETELEEE
(de la paleta Standard) y un [Properties [ProgressBarl . -- o
componente tTimer (Paleta :?" A I
in [T it
System) eroresters 12101 o
= Distribuye y cambia las Orientation pbHorizontal -+ -Buttont o~ Button2:
. Position El ..................................................
propiedades de la ventana- =

formulario como en la imagen.
» Propiedad ProgessBar1.Max = 100 ProgessBar1.Min=0 y ProgessBar1.Position =0
» Propiedad Timer1.Interval = 500 (medio segundo)

Objetivo del cédigo:
Queremos que a cada impulso del Timer, mover la posicion de la barra de 1 en 1:
—> ProgressBarl.position := ProgressBarl.position+1;
y cuando la barra llegue a 100 queremos que se pare:
—> if ProgressBarl.position=100 then ...

Pero... ¢Qué pasaria si los incrementos fuesen de 3 en 3?

Eventos: (Suceso que desencadena una accion)

» Pulsa doble clic sobre el Timer para activar el evento OnTimer del Timerl y escribe el codigo siguiente
segun la versién escogida:



Versién Delphi VCL:

procedure TForml.TimerlTimer(Sender: TObject);

begin
ProgressBarl.position := ProgressBarl.position+l; //-> incrementa la barra una posicion
if ProgressBarl.position=100 then //-> si llega a 100..
begin
Timerl.Enabled:=False; // -> Para el temporizador
ShowMessage('Transferencia realizada'); // -> muestra un mensaje
Application.Terminate; //-> termina el programa
end;
end;

Version C++Builder VCL:

void _ fastcall TForml::TimerlTimer(TObject *Sender)

{
ProgressBarl->Position++; //-> incrementa la posicidén de la barra
if (ProgressBaril->Position==100) //-> si llega a 100..
{
Timerl->Enabled=False; // -> Para el temporizador
ShowMessage("La aplicacién " + Application->ExeName+ " ha finalizado"); // -> muestra un mensaje
Application->Terminate; //-> termina el programa
}
¥

Versién Delphi MultiDevice (Firemonkey fmx):

procedure TForml.TimerlTimer(Sender: TObject);

begin
ProgressBarl.Value := ProgressBarl.Value+l; //-> incrementa la barra una posicion
if ProgressBarl.Value=100 then //-> si llega a 1@0..
begin
Timerl.Enabled:=False; // -> Para el temporizador
ShowMessage('Transferencia realizada'); // -> muestra un mensaje
Application.Terminate; //-> termina el programa
end;
end;

Version C++ Builder MultiDevice (Firemonkey fmx):

void _ fastcall TForml::TimerlTimer(TObject *Sender)

{
ProgressBarl->Value++; //incrementa la posicidn de la barra
if (ProgressBarl->Value == 100) //-> si llega a 100..
{
Timerl->Enabled=False; // -> Para el temporizador
ShowMessage("Transferencia realizada"); // -> muestra el mensaje
Application->Terminate; //-> termina el programa
}
¥

Opcional: Puedes impedir cerrar la ventana si en el evento del form: Closequery pones la variable canClose:=false;
Ejemplo: ShowMessage('No puedes cerrar la ventana mientras se transfieren los archivos'); canClose:=false;

¢, Qué pasaria si los incrementos fuesen de 3 en 37?

* Probar la aplicacion: Pulsa Run [> para comprobar su funcionamiento.
= Guardar el proyecto: Crea una carpeta en tus Projects que se llame: Transferencia
Para Delphi VCL
0 Escoge: File » Save as... Para guardar el archivo: Transferencial.pas
0 Escoge: File » Save project as... Para guarda el proyecto Transferencia.dpr
Para C++Builder VCL
o0 Escoge: File » Save as... Para guardar el archivo: Transferencial.cpp (Se crea Transferencia1.h)
0 Escoge: File » Save project as... Para guarda el proyecto Transferenciah.h y Transferenciah.cproj
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Bucles:
Infinito:
While: Repite la ejecucion infinitas veces hasta que se cumpla la condicion.

while i<10 doi :=i+1;

Finito (Contador):
For ... To, o For ... Downto:
Ejecuta una accién un numero determinado de veces.
o0 To: Incrementa cada vez el bucle
o Downto: Decrementa cada vez el bucle.

for i:=1 to 100 do
Begin
Labell. caption:='Paso numero’ + i;
Beep; // tono sonoro
End;

Ejercicio Progreso sin timer (con while)

= Crea un nuevo proyecto para Windows: File » New » Windows VCL Application (Delpphi o C++ Builder).

Disefio:

» Afiade al formulario un objeto barra de progreso tProgressBar

= Un botdn (tButton) y una etiqueta tLabel (de la paleta & Form9 e[ B[S
Standard)

= Distribuye y cambia las propiedades de la ventana- [0 o

formulario como en laimagen.

------------ Transferir archivos amicuenta: - -~ - - - - - -

Eventos: (Suceso que desencadena una accion) SRR S SRR RN RS ERNREE R

» Pulsa doble clic sobre el Boton y escribe el cédigo siguiente segun la version escogida:

procedure TForml.ButtonlClick(Sender: TObject);
begin
while ProgressBarl.Position<100 do
begin
ProgressBarl.Position := ProgressBarl.Position+1;
sleep(200);
end;
ShowMessage('Transferencia realizada'); // -> muestra un mensaje
Application.Terminate; //-> termina el programa
end;

Probar la aplicacién: Pulsa Run [> para comprobar su funcionamiento.
Ahora cambia el Cédigo por este otro y comenta la diferencia:
procedure TForml.ButtonlClick(Sender: TObject);
var
i:integer;
begin
for i:=1 to 100 do
begin
ProgressBarl.Position := ProgressBarl.Position+1;
sleep(200);
end;
ShowMessage('Transferencia realizada'); // -> muestra un mensaje
Application.Terminate; //-> termina el programa
end;




